blob: 4e17651f4a1163dafc33eb6fc88f5e7b81f9daae [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f248db1f0fc22cac2345bc128a6a0a3276c7c430"
CROS_WORKON_TREE=("0db6495c85c9186f120853ea040436bf4259ef96" "08bdf83cf4f403dd53e27531e66f3a1fd9a23881" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk hiberman .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="hiberman/client"
inherit cros-workon platform
DESCRIPTION="Hibernate manager DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/hiberman/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="cros_host"
DEPEND=""
RDEPEND=""
BDEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
# Install DBus client library.
platform_install_dbus_client_lib "hibernate"
}