blob: 6110040cbea99fa6900ab7ef8cc2d368a4de704e [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f248db1f0fc22cac2345bc128a6a0a3276c7c430"
CROS_WORKON_TREE=("0db6495c85c9186f120853ea040436bf4259ef96" "9f169e2d15cb3a0fb7ed9bf55a6a443166e10796" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/vm/mojo_proxy .gn"
PLATFORM_SUBDIR="arc/vm/mojo_proxy"
inherit cros-workon platform user
DESCRIPTION="ARCVM mojo proxy."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/arc/vm/mojo_proxy"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
dev-libs/protobuf:=
sys-fs/fuse
"
DEPEND="
${RDEPEND}
"
src_install() {
newbin "${OUT}"/server_proxy arcvm_server_proxy
insinto /etc/init
doins init/arcvm-server-proxy.conf
}
pkg_preinst() {
enewuser "arc-mojo-proxy"
enewgroup "arc-mojo-proxy"
}
platform_pkg_test() {
platform_test "run" "${OUT}/mojo_proxy_test"
}