blob: 3feec9716f891ac3b4ddebbbc8a598bda3a167f4 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk ml_benchmark .gn"
DESCRIPTION="Chrome OS ML Benchmarking Suite"
PLATFORM_SUBDIR="ml_benchmark"
inherit cros-workon platform
RDEPEND=""
DEPEND="
${RDEPEND}
"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
src_install() {
dobin "${OUT}"/ml_benchmark
}
platform_pkg_test() {
platform_test "run" "${OUT}/ml_benchmark_test"
}