blob: c2180475ebd627e1efe14d26b958ef339f9922e2 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="862dd12ce178d5299cc8843332b86e0ef7e56189"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "a6b68647eba93cad8f83eaddc189a4958d4922c8" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk ml_benchmark .gn"
DESCRIPTION="Chrome OS ML Benchmarking Suite"
PLATFORM_SUBDIR="ml_benchmark"
inherit cros-workon platform
RDEPEND=""
DEPEND="
${RDEPEND}
"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
src_install() {
dobin "${OUT}"/ml_benchmark
}
platform_pkg_test() {
platform_test "run" "${OUT}/ml_benchmark_test"
}