blob: 9eb5d600fae1631b3db2a140549609a4c5c84dba [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="cde7cb8f73a5c3d12efcd877b93dc32d2c38963a"
CROS_WORKON_TREE=("413b00cea90e3466162b7497715491c714249b3f" "ed9568e164e1e6d2d6e0ef8336987bafdb31c5e6")
CROS_RUST_SUBDIR="cras/client/cras_tests"
CROS_WORKON_LOCALNAME="adhd"
CROS_WORKON_PROJECT="chromiumos/third_party/adhd"
# We don't use CROS_WORKON_OUTOFTREE_BUILD here since cras-sys/Cargo.toml is
# using "provided by ebuild" macro which supported by cros-rust
CROS_WORKON_SUBTREE="${CROS_RUST_SUBDIR} cras/dbus_bindings"
inherit cros-workon cros-rust
DESCRIPTION="Rust version cras test client"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/adhd/+/HEAD/cras/client/cras_tests"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test"
DEPEND="
dev-rust/chromeos-dbus-bindings:=
>=dev-rust/clap-3.1.12:= <dev-rust/clap-4.0
=dev-rust/dbus-0.9*:=
dev-rust/hound:=
=dev-rust/serde_json-1*
dev-rust/sys_util:=
>=dev-rust/thiserror-1.0.20:= <dev-rust/thiserror-2.0
media-sound/audio_streams:=
media-sound/libcras:=
"
# DEPEND isn't needed in RDEPEND because nothing from this ebuild is installed
# to the cros_rust_registry.
RDEPEND="
!<=media-sound/cras_tests-0.1.0-r12
"
src_install() {
dobin "$(cros-rust_get_build_dir)/cras_tests"
}