blob: 7471d458c3a1f66dafe4564246f35b0d5f844849 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="867ba52f7243fd0d07f86eb47a87373393a13a2c"
CROS_WORKON_TREE=("198941553c123cea4774f67021c9e7da7842eeff" "8083bdbef3cd7fbbc9ec90941ff0418df2ce6d78")
CROS_WORKON_LOCALNAME="../platform/crosvm"
CROS_WORKON_PROJECT="chromiumos/platform/crosvm"
# We don't use CROS_WORKON_OUTOFTREE_BUILD here since audio_streams/Cargo.toml
# is using "provided by ebuild" macro which supported by cros-rust
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_RUST_SUBDIR="common/audio_streams"
CROS_WORKON_SUBDIRS_TO_COPY=("${CROS_RUST_SUBDIR}" .cargo)
CROS_WORKON_SUBTREE="${CROS_WORKON_SUBDIRS_TO_COPY[*]}"
inherit cros-workon cros-rust
DESCRIPTION="Crate provides a basic interface for playing audio."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/adhd/+/HEAD/audio_streams"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test"
DEPEND="
=dev-rust/async-trait-0.1*:=
=dev-rust/futures-0.3*:=
=dev-rust/remain-0.2*:=
dev-rust/sync:=
dev-rust/sys_util:=
=dev-rust/thiserror-1*:=
"
# (crbug.com/1182669): build-time only deps need to be in RDEPEND so they are pulled in when
# installing binpkgs since the full source tree is required to use the crate.
RDEPEND="${DEPEND}
!<=media-sound/audio_streams-0.1.0-r49
"