blob: 0995d4a9174fa0686ece6cffdb2a2152cc747781 [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="feb8590958f0d510e2819b0b86603cc70fc032fe"
CROS_WORKON_TREE="0e27e6033b951eee59a3d80f05b2128d50f5a409"
CROS_WORKON_PROJECT="chromiumos/platform/ec"
CROS_WORKON_LOCALNAME="platform/ec"
CROS_WORKON_INCREMENTAL_BUILD=1
inherit cros-workon
DESCRIPTION="Chrome OS EC Utility Helper"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/ec/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE="biod -cr50_onboard"
# flash_fp_mcu depends on stm32mon (ec-devutils)
RDEPEND="
chromeos-base/ec-utils
biod? (
chromeos-base/ec-devutils
dev-util/shflags
)
"
src_compile() {
tc-export CC
if use cr50_onboard; then
emake -C extra/rma_reset
fi
}
src_install() {
dobin "util/battery_temp"
dosbin "util/inject-keys.py"
if use cr50_onboard; then
dobin "extra/rma_reset/rma_reset"
fi
if use biod; then
einfo "Installing flash_fp_mcu"
dobin "util/flash_fp_mcu"
fi
}