blob: 628ba96e71c2d2b73f53847e2cbb6e9f862e9440 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("f0233f823e10ba5e459e4cd68dfc993934b2559c" "fdcd88182cfd3d40596011819c24bb4927e82d1e")
CROS_WORKON_TREE="c23255a4f2bbb7a64d7e041b2eae58db9e7d719f"
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/fw-testing-configs"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
# There are symlinks between remote data to local data, so we can't make the
# subtree "src/chromiumos/tast/remote".
# TODO(oka): have a clear separation between local and remote, and make that
# happen.
CROS_WORKON_SUBTREE=("src/chromiumos/tast")
inherit cros-workon tast-bundle-data
DESCRIPTION="Data files for remote Tast tests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests"
LICENSE="BSD-Google GPL-3"
SLOT="0/0"
KEYWORDS="*"
DEPEND="sys-firmware/ap-firmware-config:="
RDEPEND="!<chromeos-base/tast-remote-tests-cros-0.0.2"
src_install() {
tast-bundle-data_src_install
insinto /usr/share/tast/data/chromiumos/tast/remote/bundles/cros/firmware/data
doins /usr/share/ap_firmware_config/fw-config.json
}