blob: 85b4fca13518759f7510ffcd39452fabacb9c427 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f459f35d773d50b41d55dd786c61923bd27f2f92"
CROS_WORKON_TREE=("0db6495c85c9186f120853ea040436bf4259ef96" "22e73209a1f442bdb7f51b01281a5e5bae946c16" "ce7778d24b2f9bde8061cc085b6bd204ef4b8a9e" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk diagnostics/bindings diagnostics/mojom .gn"
PLATFORM_SUBDIR="diagnostics/mojom"
WANT_LIBBRILLO="no"
inherit cros-workon platform
DESCRIPTION="Chrome OS Mojo client for cros_healthd"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/diagnostics/mojo"
LICENSE="BSD-Google"
KEYWORDS="*"
src_install() {
# Install package config.
insinto /usr/"$(get_libdir)"/pkgconfig
doins cros_healthd-client.pc
# Install C++ headers.
insinto /usr/include/cros_healthd-client/diagnostics/mojom/public
doins "${S}"/public/*.mojom
doins "${OUT}"/gen/include/diagnostics/mojom/public/*.h
doins "${OUT}"/gen/include/diagnostics/mojom/public/*module
insinto /usr/include/cros_healthd-client/diagnostics/mojom/external
doins "${S}"/external/*.mojom
doins "${OUT}"/gen/include/diagnostics/mojom/external/*.h
doins "${OUT}"/gen/include/diagnostics/mojom/external/*module
# Install libraries linked by the C++ headers.
dolib.a "${OUT}"/*.a
}