blob: 72225a43991c9631bfe061c2295c0436635d911a [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="cdba8c95a061c31caea846c54623a199216a448a"
CROS_WORKON_TREE=("b4a202ab905c738735c1b0a422ad4f7c0f80e9b3" "a5b7a8cfa5fee66dae2198d608c1767f315ab13d" "893a6c65e547215a0fbd306fe773bb5e8e27f34b")
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME=("../platform/dev")
CROS_WORKON_SUBTREE="src/chromiumos/test/test_finder src/chromiumos/test/util src/chromiumos/test/execution"
inherit cros-go cros-workon
DESCRIPTION="Test finder for find tests that match the specified test suite tags"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/dev-util/+/HEAD/src/chromiumos/test/test_finder"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
CROS_GO_VERSION="${PF}"
CROS_GO_BINARIES=(
"chromiumos/test/test_finder/cmd/cros-test-finder"
)
CROS_GO_TEST=(
"chromiumos/test/test_finder/cmd/cros-test-finder/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
DEPEND="
chromeos-base/tast-cmd:=
chromeos-base/tast-proto
dev-util/cros-test
dev-util/lro-server
"
RDEPEND="${DEPEND}"
src_prepare() {
# Disable cgo and PIE on building Tast binaries. See:
# https://crbug.com/976196
# https://github.com/golang/go/issues/30986#issuecomment-475626018
export CGO_ENABLED=0
export GOPIE=0
default
}