blob: a3953359675b2cb2e2e143dedbede5c8a65190c8 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authros. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="7c9c8dde6e5540bc13e4ec3ad9a7da357011411d"
CROS_WORKON_TREE="a06262f549ab04d57db55306d37d111faa5e47a9"
CROS_WORKON_PROJECT="chromiumos/platform/glbench"
inherit cros-workon
DESCRIPTION="Microbenchmark for opengl/gles"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/glbench/"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="opengl opengles"
COMMON_DEPEND="
>=dev-cpp/gflags-2.0:=
media-libs/libpng:=
virtual/opengles:=
media-libs/waffle:="
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
x11-drivers/opengles-headers:="
src_compile() {
emake -C src
}
src_install() {
local glbench_dir="/usr/local/${PN}"
# Install the executable.
exeinto "${glbench_dir}/bin"
doexe glbench windowmanagertest
# Install the list files.
insinto "${glbench_dir}/files"
doins glbench_fixedbad_images.txt
doins glbench_knownbad_images.txt
doins glbench_reference_images.txt
}