blob: f0acd588dfd8329bd431935756f9df16224c5deb [file] [log] [blame]
# Copyright 2022 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk hiberman .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="hiberman/client"
inherit cros-workon platform
DESCRIPTION="Hibernate manager DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/hiberman/"
LICENSE="BSD-Google"
KEYWORDS="~*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "hibernate"
}