blob: ad1b2d5aa08a54bd57371074be932f8d565c1e05 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="ab646e13303ebe9518e816f85c1e4a56db88ae13"
CROS_WORKON_TREE="b27c6b2de101470684d4c17acc91d746ebc542ed"
CROS_WORKON_PROJECT="chromiumos/third_party/toolchain-utils"
CROS_WORKON_LOCALNAME="toolchain-utils"
inherit cros-workon
DESCRIPTION="Compilation and runtime tests for toolchain"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/toolchain-utils/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
RDEPEND="
app-misc/pax-utils
dev-lang/python
sys-devel/binutils
"
src_install() {
local tc_dir="/usr/$(get_libdir)/${PN}"
local dit_dir="${tc_dir}/debug_info_test"
insinto ${tc_dir}
doins -r debug_info_test
fperms a+x ${dit_dir}/debug_info_test.py
dosym ${dit_dir}/debug_info_test.py /usr/bin/debug_info_test
newbin afdo_redaction/redact_profile.py redact_textual_afdo_profile
newbin afdo_redaction/remove_indirect_calls.py remove_indirect_calls
newbin afdo_redaction/remove_cold_functions.py remove_cold_functions
}