blob: 15b2536fdfa39ccc3fc84cd8327beb592e018247 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d290f731c4d623269bf6a259a351bf92eb5f4854"
CROS_WORKON_TREE=("aa81756947ecfdd38b22f42eed8eeafa40431079" "122dcf94739d2143609ba6ddc05a199e3fc3a713" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk tpm2-simulator .gn"
PLATFORM_SUBDIR="tpm2-simulator"
inherit cros-workon platform user
DESCRIPTION="TPM 2.0 Simulator"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/tpm2-simulator/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
COMMON_DEPEND="
dev-libs/openssl:0=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="
chromeos-base/tpm2:=
${COMMON_DEPEND}
"
src_install() {
dobin "${OUT}"/tpm2-simulator
}