blob: 298d4f508ca265ef25cada9867eb1391551f0b1b [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="d290f731c4d623269bf6a259a351bf92eb5f4854"
CROS_WORKON_TREE=("aa81756947ecfdd38b22f42eed8eeafa40431079" "35feb3e318967769cca1866dd8a39a2a134575f9" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk touch_firmware_calibration .gn"
PLATFORM_SUBDIR="touch_firmware_calibration"
inherit cros-workon platform user udev
DESCRIPTION="Touch Firmware Calibration"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/touch_firmware_calibration/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
pkg_preinst() {
# Set up touch_firmware_calibration user and group which will be used to
# run tools for calibration.
enewuser touch_firmware_calibration
enewgroup touch_firmware_calibration
}
src_install() {
# Install a tool to override max pressure.
exeinto "$(get_udevdir)"
doexe "${OUT}/override-max-pressure"
# Install the correct seccomp policy for this architecture.
insinto "/usr/share/policy"
newins "seccomp/override-max-pressure-seccomp-${ARCH}.policy" override-max-pressure-seccomp.policy
}