blob: eab19d2b9bc3d9b8652f5f04740afd4d5a2dea4e [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d290f731c4d623269bf6a259a351bf92eb5f4854"
CROS_WORKON_TREE=("aa81756947ecfdd38b22f42eed8eeafa40431079" "cda0d8aecf41b95f6c4af7b6878468fddb3c26fe" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="common-mk shill/cli .gn"
PLATFORM_SUBDIR="shill/cli"
inherit cros-workon platform
DESCRIPTION="Shill Command Line Interface"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/shill/cli"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
RDEPEND="
>=chromeos-base/shill-0.0.1-r2205
"
DEPEND="
chromeos-base/shill-client:=
chromeos-base/system_api:=
"
src_install() {
dobin "${OUT}"/shillcli
}
platform_pkg_test() {
platform_test "run" "${OUT}/shillcli_test"
}