blob: f3d3ecc95fd43a89f73bf2e0ace1b4606ff1f3b0 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="7afe04b1b5bbe339947caf214ce501be818b02ee"
CROS_WORKON_TREE="efa84ee99edc2aa5b1c77cd2d6246bace6fe71ff"
PYTHON_COMPAT=( python3_{6..9} )
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon python-any-r1
DESCRIPTION="Compilation and runtime tests for toolchain"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
LICENSE="BSD-Google"
KEYWORDS="*"
src_unpack() {
cros-workon_src_unpack
S+="/client/site_tests/platform_ToolchainTests/src"
}
src_test() {
einfo "Testing llvm-profdata..."
"${FILESDIR}/llvm-profdata-test.py" || die
default
}