blob: bd01632938a02cc9437eab4cc8284e81d09c2904 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="1f9d9f4574a9655d844c7ef46f138da7228a93a9"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "e5bab9aeb635f426a5f77597edb46ad386ad0f7c" "cb410200827b0e0e8a13e27ee2d8beee28948361" "080361d5d45e74e7927e56bab774531748d1a569" "8aea57128c1adc8ea0b845047ce01733cecaf5c1" "a4c500ab9b3c0bc4232aa527a6cbd18f786338a4" "bea140d13f7cf1092e4c89a45011c04c28327972" "a625767bb59509159091f2ab0b71f8b9b4b2e353" "8a9ef8758fbc933dbbb61914e0a924d6fd9626f6")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
# iioservice/ is included just to make sandbox happy when running `gn gen`.
CROS_WORKON_SUBTREE=".gn camera/build camera/features camera/include camera/gpu camera/common chromeos-config common-mk iioservice/libiioservice_ipc"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/features/hdrnet/tests"
inherit cros-workon platform
DESCRIPTION="Chrome OS camera HDRnet integration tests"
LICENSE="BSD-Google"
KEYWORDS="*"
# 'ipu6' and 'ipu6ep' are passed to and used in BUILD.gn files.
IUSE="ipu6 ipu6ep"
BDEPEND="virtual/pkgconfig"
RDEPEND="
chromeos-base/cros-camera-android-deps:=
chromeos-base/cros-camera-libs:=
dev-cpp/benchmark:=
dev-cpp/gtest:=
media-libs/cros-camera-libgcam:=
virtual/opengles:=
"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers:=
"
src_configure() {
cros_optimize_package_for_speed
platform_src_configure
}
src_install() {
dobin "${OUT}"/hdrnet_stream_manipulator_test
dobin "${OUT}"/hdrnet_processor_impl_test
dobin "${OUT}"/hdrnet_processor_benchmark
platform_src_install
}