blob: c35f77236fb29bc4f97f70243a441c9a44e0c1f7 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2.
EAPI=7
# The dev-go/gcp* packages are all built from this repo. They should
# be updated together.
CROS_GO_SOURCE="github.com/cncf/xds:github.com/cncf/xds 01c748900fbb8fd467c4f091385123c4715312fb"
CROS_GO_PACKAGES=(
"github.com/cncf/xds/go/udpa/annotations"
"github.com/cncf/xds/go/xds/annotations/v3"
"github.com/cncf/xds/go/xds/core/v3"
"github.com/cncf/xds/go/xds/type/matcher/v3"
)
CROS_GO_TEST=(
"${CROS_GO_PACKAGES[@]}"
)
inherit cros-go
DESCRIPTION="xDS API Working Group (xDS-WG)"
HOMEPAGE="https://github.com/cncf/xds"
SRC_URI="$(cros-go_src_uri)"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RESTRICT="binchecks"
DEPEND="
dev-go/ep-pvg
"
RDEPEND="${DEPEND}"