blob: 86e8b9f1eb629036783d0320058b33c0071eeb25 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="9e62f787bdb066d6f6d187ba4c5614e81a2289c7"
CROS_WORKON_TREE="22dce69eb9b87f1074930ff8ca5592eb2312c7da"
CROS_WORKON_PROJECT="chromiumos/platform/tast"
CROS_WORKON_LOCALNAME="platform/tast"
inherit cros-go cros-workon
CROS_GO_VERSION="${PF}"
CROS_GO_PACKAGES=(
"chromiumos/tast/framework/protocol/..."
)
CROS_GO_TEST=(
"${CROS_GO_PACKAGES[@]}"
)
DESCRIPTION="Provides go bindings to proto APIs for tast"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
DEPEND=""
RDEPEND=""
src_install() {
insinto /usr/lib/gopath/src/
cros-go_src_install
}