blob: 8c8db9648152a3035243c0a3c80b2213b6f9f0dd [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("f35f2919309cf11b0ddd9deb24a6b145d40d9254" "fc39c8b509da8a45869d7c0e44b263dd631c6fb4")
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "0976a2b7b2acb179add29936ed65851ab6662c95")
inherit cros-constants
CROS_WORKON_LOCALNAME=(
"platform2"
"platform/pinweaver"
)
CROS_WORKON_PROJECT=(
"chromiumos/platform2"
"chromiumos/platform/pinweaver"
)
CROS_WORKON_OPTIONAL_CHECKOUT=(
"true"
"true"
)
CROS_WORKON_DESTDIR=(
"${S}/platform2"
"${S}/platform2/pinweaver"
)
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE=(
"common-mk .gn"
""
)
PLATFORM_SUBDIR="pinweaver"
inherit cros-workon platform
DESCRIPTION="PinWeaver code that can be used across implementation platforms."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/pinweaver/+/main/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
src_install() {
dolib.a "${OUT}"/libpinweaver.a
insinto /usr/include/pinweaver
doins eal/tpm_storage/pinweaver_eal_types.h
doins pinweaver.h
doins pinweaver_eal.h
doins pinweaver_types.h
}