blob: 59391a6478d696733c92a92db4ee91839c4d7bc3 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f35f2919309cf11b0ddd9deb24a6b145d40d9254"
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "fdd0209826719268c01d190ed7bbfa76b177f2f5" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk ml_benchmark .gn"
DESCRIPTION="Chrome OS ML Benchmarking Suite"
PLATFORM_SUBDIR="ml_benchmark"
inherit cros-workon platform
# chromeos-base/ml_benchmark blocked due to package rename
RDEPEND="
!chromeos-base/ml_benchmark
vulkan? ( media-libs/clvk )
"
DEPEND="${RDEPEND}
dev-libs/protobuf:=
"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="vulkan"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}