blob: ae9c5312979e15ffcdc3416e83ae23908585adb2 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_USE_VCSID="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="biod common-mk libec .gn"
PLATFORM_SUBDIR="libec"
inherit cros-workon platform
DESCRIPTION="Embedded Controller Library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/libec"
LICENSE="BSD-Google"
KEYWORDS="~*"
COMMON_DEPEND=""
RDEPEND="
${COMMON_DEPEND}
"
DEPEND="
${COMMON_DEPEND}
chromeos-base/chromeos-ec-headers:=
"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}