blob: 6c768a3f6cdf85dee55fe1411e0683f729568b6c [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="f35f2919309cf11b0ddd9deb24a6b145d40d9254"
CROS_WORKON_TREE=("3e8ec46db7a894d8f90bf457f66dbe4e3efad0e1" "a625767bb59509159091f2ab0b71f8b9b4b2e353" "6b093b609ed7d0c59dd0e0b5656c9fe306ad3127" "fb2b8277318fb7e7eff84f5c7669a46bf60f19f5" "b1c7898d3f42051cbba6426c62b35476a8de5b72" "97266a4772907835fdab5d56b3ca24ed9c1c7a0e" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="attestation common-mk hwsec-test-utils libhwsec libhwsec-foundation trunks .gn"
PLATFORM_SUBDIR="hwsec-test-utils"
inherit cros-workon platform
DESCRIPTION="Hwsec-related test-only features. This package resides in test images only."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/hwsec-test-utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test tpm tpm_dynamic tpm2"
REQUIRED_USE="
tpm_dynamic? ( tpm tpm2 )
!tpm_dynamic? ( ?? ( tpm tpm2 ) )
"
RDEPEND="
tpm2? (
chromeos-base/trunks:=
)
tpm? (
app-crypt/trousers:=
)
"
DEPEND="${RDEPEND}
tpm2? (
chromeos-base/trunks:=[test?]
)
chromeos-base/attestation:=
chromeos-base/libhwsec-foundation:=
chromeos-base/system_api:=
dev-libs/openssl:=
dev-libs/protobuf:=
"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}