blob: 55c50d9a439ecaa3026d2e5013c05213a5d901d9 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="common-mk hps .gn metrics"
PLATFORM_SUBDIR="hps/util"
inherit cros-workon platform
DESCRIPTION="HPS utilities and tool"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/main/hps"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="~*"
COMMON_DEPEND="
chromeos-base/metrics:=
virtual/libusb:1
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
src_install() {
platform_src_install
dobin "${OUT}"/hps
}