blob: 815a47651461a6a0a4638c3dd4c83f51978ece81 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f35f2919309cf11b0ddd9deb24a6b145d40d9254"
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "3b4d7f82f5d68f35d2412d679e794ec15a3a45e0" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk foomatic_shell .gn"
PLATFORM_SUBDIR="foomatic_shell"
inherit cros-workon platform
DESCRIPTION="Mini shell used by foomatic-rip to execute scripts in PPD files."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/foomatic_shell/"
LICENSE="BSD-Google"
KEYWORDS="*"
src_install() {
dobin "${OUT}/foomatic_shell"
# Install fuzzer
local fuzzer_component_id="167231"
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/foomatic_shell_fuzzer \
--comp "${fuzzer_component_id}"
}
platform_pkg_test() {
platform_test "run" "${OUT}/foomatic_shell_test"
}