blob: 73e0e55db9507751de6e057f8a115bf886dfbf92 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk diagnostics/mojom .gn"
PLATFORM_SUBDIR="diagnostics/mojom"
WANT_LIBBRILLO="no"
inherit cros-workon platform
DESCRIPTION="Chrome OS Mojo client for cros_healthd"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/diagnostics/mojo"
LICENSE="BSD-Google"
KEYWORDS="~*"
src_install() {
# Install package config.
insinto /usr/"$(get_libdir)"/pkgconfig
doins cros_healthd-client.pc
# Install C++ headers.
insinto /usr/include/cros_healthd-client/diagnostics/mojom/public
doins "${S}"/public/*.mojom
doins "${OUT}"/gen/include/diagnostics/mojom/public/*.h
doins "${OUT}"/gen/include/diagnostics/mojom/public/*module
insinto /usr/include/cros_healthd-client/diagnostics/mojom/external
doins "${S}"/external/*.mojom
doins "${OUT}"/gen/include/diagnostics/mojom/external/*.h
doins "${OUT}"/gen/include/diagnostics/mojom/external/*module
# Install libraries linked by the C++ headers.
dolib.a "${OUT}"/*.a
}