blob: 1b810778a3b0cb50a02dd657bd5a88c017e461e0 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f35f2919309cf11b0ddd9deb24a6b145d40d9254"
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "36b901d31b2b1858ec25d421e23ed3de8f75dcde" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk diagnostics/mojom .gn"
PLATFORM_SUBDIR="diagnostics/mojom"
WANT_LIBBRILLO="no"
inherit cros-workon platform
DESCRIPTION="Chrome OS Mojo client for cros_healthd"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/diagnostics/mojo"
LICENSE="BSD-Google"
KEYWORDS="*"
src_install() {
# Install package config.
insinto /usr/"$(get_libdir)"/pkgconfig
doins cros_healthd-client.pc
# Install C++ headers.
insinto /usr/include/cros_healthd-client/diagnostics/mojom/public
doins "${S}"/public/*.mojom
doins "${OUT}"/gen/include/diagnostics/mojom/public/*.h
doins "${OUT}"/gen/include/diagnostics/mojom/public/*module
insinto /usr/include/cros_healthd-client/diagnostics/mojom/external
doins "${S}"/external/*.mojom
doins "${OUT}"/gen/include/diagnostics/mojom/external/*.h
doins "${OUT}"/gen/include/diagnostics/mojom/external/*module
# Install libraries linked by the C++ headers.
dolib.a "${OUT}"/*.a
}