blob: 20517452e8d65af5937020b484b930e2c10e76bf [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk client_id .gn"
PLATFORM_SUBDIR="client_id"
inherit cros-workon platform
DESCRIPTION="Utility to generate Client ID for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/client_id"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
src_install() {
dobin "${OUT}"/client_id
}
platform_pkg_test() {
platform_test "run" "${OUT}/client_id_test"
}