blob: 14b2af28b4ce252c31630fe2ead03a3fe196cbf6 [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f35f2919309cf11b0ddd9deb24a6b145d40d9254"
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "44fee33df1d1e1d19aa6078be1f5c33590102ac8" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk client_id .gn"
PLATFORM_SUBDIR="client_id"
inherit cros-workon platform
DESCRIPTION="Utility to generate Client ID for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/client_id"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
src_install() {
dobin "${OUT}"/client_id
}
platform_pkg_test() {
platform_test "run" "${OUT}/client_id_test"
}