blob: 19045b16a8852d3b47255fd21f3f7e442e06dc42 [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="f35f2919309cf11b0ddd9deb24a6b145d40d9254"
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "3f549951f59cf658c62f70f4e1a93a61ebb06f64" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk image-burner .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="image-burner"
inherit cros-workon platform user
DESCRIPTION="Image-burning service for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/image-burner/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="user_session_isolation"
RDEPEND="
sys-apps/rootdev
"
DEPEND="${RDEPEND}
chromeos-base/system_api
"
pkg_preinst() {
# Create user and group for image-burner.
enewuser "image-burner"
enewgroup "image-burner"
}
src_install() {
platform_install
# TODO(crbug/766130): Remove the following sed block when non-root mount
# namespace is by default enabled.
# Remove the env var value related to mount namespace if USE flag
# user_session_isolation is not present.
if ! use user_session_isolation; then
sed -i -e "/env MNT_NS_ARGS=/s:=.*:=:" \
"${D}"/etc/init/image-burner.conf || die
fi
}
platform_pkg_test() {
platform test_all
}