blob: 9028adbc9fa301c0a716b81fc239a73f423a95af [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="da9f7231d7dd7f2f80b01f90fa1b62df4bac374b"
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "6aa5fab60458b8bc2670f2776eb8f35061c01dfc" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-dbus-bindings .gn"
PLATFORM_SUBDIR="${PN}"
PLATFORM_NATIVE_TEST="yes"
inherit cros-workon platform
DESCRIPTION="Utility for building Chrome D-Bus bindings from an XML description"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/chromeos-dbus-bindings"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="
dev-libs/expat
sys-apps/dbus"
DEPEND="${RDEPEND}"
src_install() {
dobin "${OUT}"/generate-chromeos-dbus-bindings
local fuzzer_component_id="931982"
platform_fuzzer_install "${S}"/OWNERS \
"${OUT}"/chromeos_dbus_bindings_signature_fuzzer \
--comp "${fuzzer_component_id}"
}
platform_pkg_test() {
platform_test "run" "${OUT}/chromeos_dbus_bindings_unittest"
}