blob: 433e2bfcaf44c8beb653b9609df2df87b3891b31 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f35f2919309cf11b0ddd9deb24a6b145d40d9254"
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "5df5bfc5be67365c831d204e61a7ba0722fe58c2" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/apk-cache .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="arc/apk-cache"
inherit cros-workon platform
DESCRIPTION="Maintains APK cache in ARC."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/apk-cache"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="+seccomp"
RDEPEND="
chromeos-base/minijail
dev-db/sqlite:=
"
DEPEND="
dev-db/sqlite:=
"
src_install() {
platform_install
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/apk_cache_database_fuzzer \
--comp 157100
}
platform_pkg_test() {
platform test_all
}