blob: 8a36a86a3a303ebc145f28bb9463dbe4d3d307f3 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("3b076152f3e7f4521c3237cf3680ad22a603aa55" "b1fb85673bd75c54dae214fc3d7764672916819d" "72df0f2b89ecca6d2f823038c6422fe5b898a0fb")
CROS_WORKON_TREE=("e07b21737e42e3780e72fea0c67923eb39655d0d" "4ddc1331cc37b407523e4c42a01d9d6cdbe6d9eb" "3f2804fd986e4f3dabfe8baa51297be1f057f7d3")
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/tast"
"chromiumos/platform/fw-testing-configs"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast"
"platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/tast-base"
"${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_GO_WORKSPACE=(
"${CROS_WORKON_DESTDIR[@]}"
)
CROS_GO_TEST=(
# Also test support packages that live above remote/bundles/.
"chromiumos/tast/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
TAST_BUNDLE_EXCLUDE_DATA_FILES="1"
inherit cros-workon tast-bundle
DESCRIPTION="Bundle of remote integration tests for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND="
chromeos-base/tast-tests-remote-data
dev-python/pillow
media-libs/opencv
"