blob: 170f93a693c9b4f4df3ed63d09bfcd9ebbc041ae [file] [log] [blame]
# Copyright 2015 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5f6a16045ee68aa774d359e42b960fa2dbca46a9"
CROS_WORKON_TREE=("b087d67fb825144293443ca40ea96e830e5a21f0" "bc39b610041db41153f32d07796e25f6039aabfa" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk shill .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="shill/client"
# D-Bus proxy autogenerated headers require libchrome/libbrillo headers.
WANT_LIBCHROME="yes"
WANT_LIBBRILLO="yes"
inherit cros-workon platform
DESCRIPTION="Shill DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/shill/"
LICENSE="BSD-Google"
KEYWORDS="*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
RDEPEND="
!<chromeos-base/shill-0.0.2
"
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "shill"
}