blob: 3a2e16cdb7b06311d15bb8b05d1da9852e47994e [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="d290f731c4d623269bf6a259a351bf92eb5f4854"
CROS_WORKON_TREE=("aa81756947ecfdd38b22f42eed8eeafa40431079" "19d0eae21d9d6d9902ab4b843257f1a54986088c" "e8a973464784e588992988988eb26cfa0cf5f67b" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk tpm_softclear_utils trunks .gn"
PLATFORM_SUBDIR="tpm_softclear_utils"
inherit cros-workon platform
DESCRIPTION="Utilities for soft-clearing TPM. This package resides in test images only."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/tpm_softclear_utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test tpm tpm2"
REQUIRED_USE="tpm2? ( !tpm )"
RDEPEND="
tpm2? (
chromeos-base/trunks:=
)
!tpm2? (
app-crypt/trousers:=
)
"
DEPEND="${RDEPEND}
tpm2? (
chromeos-base/system_api:=
chromeos-base/trunks:=[test?]
)
"
src_install() {
# Installs the utilities executable.
insinto /usr/local/bin
doins "${OUT}/tpm_softclear"
chmod u+x "${D}/usr/local/bin/tpm_softclear"
}
platform_pkg_test() {
platform_test "run" "${OUT}/tpm_softclear_utils_testrunner"
}