blob: 5975bbb40d3eb0bef64309d6fc8bfd6532de16e6 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d290f731c4d623269bf6a259a351bf92eb5f4854"
CROS_WORKON_TREE=("aa81756947ecfdd38b22f42eed8eeafa40431079" "ee81aa021a8e2f8e763e000672a9b75559ec582e" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk screenshot .gn"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
PLATFORM_SUBDIR="screenshot"
inherit cros-workon platform
DESCRIPTION="Utility to take a screenshot"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/screenshot/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
RDEPEND="
media-libs/libpng:0=
media-libs/minigbm:=
x11-libs/libdrm:=
virtual/opengles"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers"
src_install() {
dosbin "${OUT}/screenshot"
}