blob: 898b66e75408b54ae790e439f2c0db9d774dfd3c [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="d290f731c4d623269bf6a259a351bf92eb5f4854"
CROS_WORKON_TREE=("264bb1bf0f00bb187ac184fd6dedeffeba8be970" "aa81756947ecfdd38b22f42eed8eeafa40431079" "8bfca2f1ed038e0e416fc64153834ad974b30e7b" "e8a973464784e588992988988eb26cfa0cf5f67b" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="attestation common-mk hwsec-test-utils trunks .gn"
PLATFORM_SUBDIR="hwsec-test-utils"
inherit cros-workon platform
DESCRIPTION="Hwsec-related test-only features. This package resides in test images only."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/hwsec-test-utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test tpm tpm2"
REQUIRED_USE="tpm2? ( !tpm )"
RDEPEND="
tpm2? (
chromeos-base/trunks:=
)
!tpm2? (
app-crypt/trousers:=
)
"
DEPEND="${RDEPEND}
tpm2? (
chromeos-base/trunks:=[test?]
)
chromeos-base/attestation:=
chromeos-base/system_api:=
dev-libs/openssl:=
dev-libs/protobuf:=
"
src_install() {
# Installs attestation-injected-keys
dobin "${OUT}/attestation-injected-keys"
# Installs hwsec-test-va
dobin "${OUT}/hwsec-test-va"
# Install fake pca agent
insinto /etc/init
doins fake_pca_agent/fake_pca_agentd.conf
dobin "${OUT}"/fake_pca_agentd
}
platform_pkg_test() {
platform_test "run" "${OUT}/hwsec-test-utils_testrunner"
}