blob: 88aac08ca8f9d4c0f681c5725b6b94f15011b01f [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="2c9b005aa277b1e1253a0d52052aa97f66156a5f"
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "105444f877cd60a0891b6fc482f37379a376aba2" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk cryptohome .gn"
PLATFORM_SUBDIR="cryptohome/client"
inherit cros-workon platform
DESCRIPTION="Cryptohome D-Bus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/cryptohome"
LICENSE="BSD-Google"
KEYWORDS="*"
# D-Bus proxies generated by this client library depend on the code generator
# itself (chromeos-dbus-bindings) and produce header files that rely on
# libbrillo library, hence both dependencies.
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# r3700 because we moved the dbus headers for UserDataAuth from cryptohome into
# cryptohome-client in that version.
RDEPEND="
!<chromeos-base/cryptohome-0.0.1-r3700
"
src_install() {
# Install D-Bus client library.
platform_install_dbus_client_lib "user_data_auth"
}