blob: 8a0a0f9b9441744a9cee6d620f09ab19dea1f14d [file] [log] [blame]
# Copyright (C) 2012 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE.makefile file.
# A note about this ebuild: this ebuild is Unified Build enabled but
# not in the way in which most other ebuilds with Unified Build
# knowledge are: the primary use for this ebuild is for engineer-local
# work or firmware builder work. In both cases, the build might be
# happening on a branch in which only one of many of the models are
# available to build. The logic in this ebuild succeeds so long as one
# of the many models successfully builds.
# Increment the "eclass bug workaround count" below when you change
# "cros-ec.eclass" to work around http://crbug.com/220902.
#
# eclass bug workaround count: 3
EAPI=7
CROS_WORKON_COMMIT=("e839b88e62457b84b5ebb324a924551732651f47" "92221d4688ed01cc361f01d650b82bf7e28078b2")
CROS_WORKON_TREE=("0d9f9923bc50cdfc36416f33f1573f9ab0f4059c" "2aeca3cffd0e69db866b5623819ecd5bf8db1232")
CROS_WORKON_PROJECT=(
"chromiumos/platform/ec"
"chromiumos/third_party/cryptoc"
)
CROS_WORKON_LOCALNAME=(
"platform/ec"
"third_party/cryptoc"
)
CROS_WORKON_DESTDIR=(
"${S}/platform/ec"
"${S}/third_party/cryptoc"
)
inherit cros-ec cros-workon
# Make sure config tools use the latest schema.
BDEPEND=">=chromeos-base/chromeos-config-host-0.0.2"
MIRROR_PATH="gs://chromeos-localmirror/distfiles/"
DESCRIPTION="Embedded Controller firmware code"
KEYWORDS="*"
# Restrict strip because chromeos-ec package installs unstrippable firmware.
RESTRICT="strip"