blob: bf6ace6902db673fc4d35cca7834151ee3a302b7 [file] [log] [blame]
# Copyright 2015 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="acc97fe43f7940139b0f739b2a71364b8b5ead8f"
CROS_WORKON_TREE=("1a76f115a513f7aedc02c1cc9ea9f5229c662d06" "e69523e5038c4de60fcaa5d506a89614f76cf502" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk shill .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="shill/client"
# D-Bus proxy autogenerated headers require libchrome/libbrillo headers.
WANT_LIBCHROME="yes"
WANT_LIBBRILLO="yes"
inherit cros-workon platform
DESCRIPTION="Shill DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/shill/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
RDEPEND="
!<chromeos-base/shill-0.0.2
"
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "shill"
}