blob: 4fb6f6eff57ae58d7f6540a90133b230ec2436be [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("f34cf3a06f7b17b7829185630d886a5d9d3f0e75" "6f68cdae2db46345996be0bac9c59e6fbabb5e4f")
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "28cbb351025522a4f769aec6fc01bfb93d49208b")
CROS_WORKON_PROJECT=("chromiumos/platform2" "chromiumos/platform/tast-tests")
CROS_WORKON_LOCALNAME=("platform2" "platform/tast-tests")
CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/tast-tests")
CROS_WORKON_SUBTREE=("common-mk .gn" "helpers")
PLATFORM_SUBDIR="tast-tests/helpers/local"
inherit cros-workon platform
DESCRIPTION="Compiled executables used by local Tast tests in the cros bundle"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/+/master/helpers"
LICENSE="BSD-Google GPL-3"
SLOT="0/0"
KEYWORDS="*"
COMMON_DEPEND="
dev-cpp/gtest:=
media-libs/minigbm:=
x11-libs/libdrm:=
"
RDEPEND="
${COMMON_DEPEND}
chromeos-base/goldctl
"
DEPEND="${RDEPEND}"
src_install() {
# Executable files' names take the form <category>.<TestName>.<bin_name>.
exeinto /usr/libexec/tast/helpers/local/cros
doexe "${OUT}"/*.[A-Z]*.*
# Install symbol list file to the location required by minidump_stackwalk.
# See https://www.chromium.org/developers/decoding-crash-dumps for details.
local crasher_exec="${OUT}/platform.UserCrash.crasher"
local id=$(head -n1 "${crasher_exec}.sym" | cut -d' ' -f 4)
insinto "/usr/libexec/tast/helpers/local/cros/symbols/${crasher_exec##*/}/${id}"
doins "${crasher_exec}.sym"
}