blob: 6ec4f02b53fdb209b690554581a24d9e18f9b55a [file] [log] [blame]
# Copyright (c) 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="3295e677c8f2e9236d520373c77a9115a0a36fa9"
CROS_WORKON_TREE="9f106081447f3fb142fa0718f95458437296f96d"
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME="platform/dev"
CROS_WORKON_OUTOFTREE_BUILD="1"
inherit cros-workon
DESCRIPTION="Server to cache Chromium OS build artifacts from Google Storage."
HOMEPAGE="http://dev.chromium.org/chromium-os/how-tos-and-troubleshooting/using-the-dev-server"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
dev-lang/python
dev-python/protobuf-python
dev-python/cherrypy
net-misc/gsutil
!<chromeos-base/cros-devutils-1
"
DEPEND="
dev-python/psutil
"
src_install() {
emake install DESTDIR="${D}"
}
src_test() {
# Run the unit tests.
./run_unittests || die
}