| # Copyright 2021 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI="7" |
| |
| CROS_WORKON_PROJECT=("chromiumos/platform2" "aosp/platform/system/bt" "aosp/platform/system/bt") |
| CROS_WORKON_LOCALNAME=("../platform2" "../aosp/system/bt/upstream" "../aosp/system/bt/bringup") |
| CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/bt" "${S}/platform2/bt") |
| CROS_WORKON_SUBTREE=("common-mk .gn" "" "") |
| CROS_WORKON_OPTIONAL_CHECKOUT=( |
| "" |
| "use !bt-bringup" |
| "use bt-bringup" |
| ) |
| |
| PLATFORM_SUBDIR="bt" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Bluetooth Tools and System Daemons for Linux" |
| HOMEPAGE="https://android.googlesource.com/platform/system/bt/" |
| |
| LICENSE="Apache-2.0" |
| KEYWORDS="~*" |
| IUSE="bt-bringup" |
| REQUIRED_USE="?? ( bt-bringup )" |
| |
| DEPEND=" |
| dev-libs/modp_b64:= |
| dev-libs/tinyxml2:= |
| " |
| |
| RDEPEND="${DEPEND}" |
| |
| DOCS=( README.md ) |