| # Copyright 2019 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI="7" |
| |
| CROS_RUST_SUBDIR="cras/client/cras-sys" |
| # TODO(b/175640259) Fix tests for ARM. |
| CROS_RUST_TEST_DIRECT_EXEC_ONLY="yes" |
| |
| CROS_WORKON_LOCALNAME="adhd" |
| CROS_WORKON_PROJECT="chromiumos/third_party/adhd" |
| # We don't use CROS_WORKON_OUTOFTREE_BUILD here since cras-sys/Cargo.toml is |
| # using "provided by ebuild" macro which supported by cros-rust. |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_SUBTREE="${CROS_RUST_SUBDIR} cras/src/common" |
| |
| inherit cros-workon cros-rust |
| |
| DESCRIPTION="Crate for CRAS C-structures generated by bindgen" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/adhd/+/HEAD/cras/client/cras-sys" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="test" |
| |
| DEPEND=" |
| dev-rust/data_model:= |
| media-sound/audio_streams:= |
| virtual/bindgen:= |
| " |
| # (crbug.com/1182669): build-time only deps need to be in RDEPEND so they are pulled in when |
| # installing binpkgs since the full source tree is required to use the crate. |
| RDEPEND="${DEPEND} |
| !<=media-sound/cras-sys-0.1.0-r10 |
| " |