blob: f59f50588076f38e7c9e1d66bff16e629b543751 [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cros-constants
CROS_RUST_SUBDIR="rust/vboot_reference-sys"
CROS_WORKON_PROJECT="chromiumos/platform/vboot_reference"
CROS_WORKON_LOCALNAME="../platform/vboot_reference"
CROS_WORKON_SUBTREE="host/include rust/vboot_reference-sys"
inherit cros-workon cros-rust
DESCRIPTION="Chrome OS verified boot tools Rust bindings"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+/HEAD/rust"
LICENSE="BSD-Google"
KEYWORDS="~*"
# ebuilds that install executables and depend on vboot_reference-sys need to
# RDEPEND on chromeos-base/vboot_reference
DEPEND="
chromeos-base/vboot_reference:=
>=dev-rust/libc-0.2.44:= <dev-rust/libc-0.3.0
>=dev-rust/pkg-config-0.3.0:= <dev-rust/pkg-config-0.4.0
=dev-rust/which-4*:=
>=virtual/bindgen-0.59:=
"
# (crbug.com/1182669): build-time only deps need to be in RDEPEND so they are pulled in when
# installing binpkgs since the full source tree is required to use the crate.
RDEPEND="${DEPEND}"