blob: 7767f5af9646407a5028f7d5d49ae971b8995339 [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_RUST_REMOVE_DEV_DEPS=1
inherit cros-rust
DESCRIPTION='Date and time library. Fully interoperable with the standard library. Mostly compatible with #![no_std].'
HOMEPAGE='https://time-rs.github.io'
SRC_URI="https://crates.io/api/v1/crates/${PN}/${PV}/download -> ${P}.crate"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="${PV}/${PR}"
KEYWORDS="*"
DEPEND="
>=dev-rust/itoa-1.0.1 <dev-rust/itoa-2.0.0_alpha:=
>=dev-rust/quickcheck-1.0.3 <dev-rust/quickcheck-2.0.0_alpha:=
>=dev-rust/rand-0.8.4 <dev-rust/rand-0.9.0_alpha:=
>=dev-rust/serde-1.0.126 <dev-rust/serde-2.0.0_alpha:=
~dev-rust/time-macros-0.2.4:=
>=dev-rust/libc-0.2.98 <dev-rust/libc-0.3.0_alpha:=
>=dev-rust/num_threads-0.1.2 <dev-rust/num_threads-0.2.0_alpha:=
"
RDEPEND="${DEPEND}"
# This file was automatically generated by cargo2ebuild.py