blob: 5bb741959abb5be9f4f9137977e30c6a1ef9cfff [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="bd1e9c1e5b99575aae4c3cbd6a2c102d567a7517"
CROS_WORKON_TREE=("1341afbe61e8ddabb7a86b15e553b65d92db921d" "a0d8550678a1ed2a4ab62782049032a024bf40df" "a96eb8a2b84ea10696f5a6e64a2a3054dff17d99" "c7bd7c1304c81d7c3da4a5a1c334537d2a9a8226" "8829a5a24648f7ac6d85554f6e0e8bb8ac9cde29" "f43eb63aebfc423dae23b8ea345bb79d455c0e7b" "74d020c63f65b15d7fd8123e792b7c503561f297" "ddd22f0572ba73430977571c1084513fb9c7fcc3" "5807b49f2a89205c10a0208e1124edffbff205af")
CROS_RUST_SUBDIR="system_api"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE="${CROS_RUST_SUBDIR} authpolicy/dbus_bindings cryptohome/dbus_bindings debugd/dbus_bindings dlcservice/dbus_adaptors login_manager/dbus_bindings shill/dbus_bindings power_manager/dbus_bindings vtpm"
inherit cros-workon cros-rust
DESCRIPTION="Chrome OS system API D-Bus bindings for Rust."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/system_api/"
LICENSE="BSD-Google"
SLOT="0/${PVR}"
KEYWORDS="*"
DEPEND="
dev-rust/chromeos-dbus-bindings:=
=dev-rust/dbus-0.9*:=
>=dev-rust/protobuf-2.16.2:= <dev-rust/protobuf-3
>=dev-rust/protoc-rust-2.16.2:= <dev-rust/protoc-rust-3
"
# (crbug.com/1182669): build-time only deps need to be in RDEPEND so they are pulled in when
# installing binpkgs since the full source tree is required to use the crate.
RDEPEND="${DEPEND}
!chromeos-base/system_api-rust
"
src_install() {
# We don't want the build.rs to get packaged with the crate. Otherwise
# we will try and regenerate the bindings.
rm build.rs || die "Cannot remove build.rs"
cros-rust_src_install
}