blob: 2b77259ca50ffc914925e679331fa94db1ab4301 [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_RUST_REMOVE_DEV_DEPS=1
inherit cros-rust
DESCRIPTION='A collection of numeric types and traits for Rust, including bigint,
complex, rational, range iterators, generic integers, and more!'
HOMEPAGE='https://github.com/rust-num/num'
SRC_URI="https://crates.io/api/v1/crates/${PN}/${PV}/download -> ${P}.crate"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="${PV}/${PR}"
KEYWORDS="*"
DEPEND="
>=dev-rust/num-bigint-0.2.5 <dev-rust/num-bigint-0.3.0_alpha:=
>=dev-rust/num-complex-0.2.4 <dev-rust/num-complex-0.3.0_alpha:=
>=dev-rust/num-integer-0.1.42 <dev-rust/num-integer-0.2.0_alpha:=
>=dev-rust/num-iter-0.1.40 <dev-rust/num-iter-0.2.0_alpha:=
>=dev-rust/num-rational-0.2.3 <dev-rust/num-rational-0.3.0_alpha:=
>=dev-rust/num-traits-0.2.11 <dev-rust/num-traits-0.3.0_alpha:=
"
RDEPEND="${DEPEND}"
# This file was automatically generated by cargo2ebuild.py