blob: 7d7e9a1c401af216e1f71f021e0bea5400e40bb2 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="2b1c44b5ca6f50123a5bbbab7d2522b2d83fa5bc"
CROS_WORKON_TREE="62c91cc57f4bbb759cc97766a681ed0c7deac706"
CROS_RUST_SUBDIR="common/cros-fuzz"
CROS_WORKON_LOCALNAME="../platform/crosvm"
CROS_WORKON_PROJECT="chromiumos/platform/crosvm"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="" # TODO(b/195126527): limit subtree to common/
CROS_WORKON_EGIT_BRANCH="chromeos"
inherit cros-workon cros-rust
DESCRIPTION="Support crate for running rust fuzzers on Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/cros-fuzz"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="fuzzer test"
DEPEND="
=dev-rust/rand_core-0.4*:=
=dev-rust/rand_core-0.6*:=
"
# (crbug.com/1182669): build-time only deps need to be in RDEPEND so they are pulled in when
# installing binpkgs since the full source tree is required to use the crate.
RDEPEND="${DEPEND}"